Add a Keyboard Shortcut to Punch and Roll for Twisted Wave

Select TwistedWave in Automator

If you are using my AppleScript that adds Punch and Roll to TwistedWave and want to assign a Keyboard Shortcut to the script, follow the steps outlined below. Any image that has been reduced in size to fit the page can be enlarged by clicking on it.

1. In your Applications folder, double click on Automator. When Automator opens, select Service, then click Choose to begin.

Select Service in Automator

 

2. Then set Service receives to no input and choose Other from the drop down labeled in.

Set service receives and other in Automator

3. Select TwistedWave from the window that appears.

Select TwistedWave in Automator

4. Double click Run AppleScript to reveal the Scripting Window

punch-roll-4

 

5. Open the TwistedWave – Punch and Roll script (highlighted in blue) from the original download. Be certain this is the same role where you modified the delay to work best on your computer.

punch-roll-5

 

6. Copy (COMMAND + C) the script from TwistedWave – Punch and Roll

Copy AppleScript

7. Select All (COMMAND + A) and Paste (COMMAND + V) into the Automator window labeled Run AppleScript

Paste AppleScript into Automator

8. Click the Hammer Icon to Validate the script. If there is an error, back up to step #6 and be certain that you use Select All in both the AppleScript Editor and Automator Windows

Add AppleScript to automator

 

Validate AppleScript

9. From the File Menu in Automator, Save the service and name it something like Punch and Roll.

Save in Automator

 

Name the Service Punch and Roll

10. From the Apple Menu, open System Preferences, choose Keyboard, then choose the Shortcuts tab. Choose Services on the left and scroll to the bottom of the list on the right. Under General you will see your Punch and Roll Service. Click where it says Add Shortcut to add a shortcut.

Open System Preferences

 

Edit Shortcuts in Keyboard Preferences

 

Assign Shortcut to Service

11. If you find that the delay time needs to be changed to make it behave properly as a Service, just open Automator and open Punch and Roll from the File > Open Recent Menu

Automator Open Recent

12. If you ever want to delete the Service completely, you can find it at: /users/YOURNAME/Library/Services/

Services Folder

A Cup of Coffee

A ridiculous amount of caffeine was consumed while researching all of this stuff.
Add some fuel if you would like to help keep me going!
$5$10$15$20$25Other

 

23 thoughts on “Add a Keyboard Shortcut to Punch and Roll for Twisted Wave

  1. I followed the directions perfectly but nothing happens when I invoke the keystroke. This is the first time I’ve used automator. Can something be getting in the way?

    1. David, does it work for you if you simply click on the script and run it (without Automator)? Also, can you try opening the Apple Menu, going down to Services and choosing Punch and Roll from there? I am wondering if your problem is isolated to the keystroke or is it something else.

      1. Hi Steven,
        It runs when I click on the script and when I go to the Apple menu , go to recent items and choose punch and roll. I tried three or four different keys strokes and none of them worked after following your direction.s.

        But, as I wrote in the other thread, regardless it doesn’t work for me correctly, instead of going back three seconds, it goes back to the start of the file regardless of length and then goes into recording at the end of the file.
        I wonder if that’s a preference I have wrong in TW.

        Thanks so much for your help, When I can get it working properly it’s going save me a ton of time as I’m starting my fourth book.

        David

        1. Hi David, this seems a bit too complex to work out here. I’ll send you an email. Let me see if I can help you resolve it. Once we have an answer, we can post it here to this thread.

  2. Steven,
    I’ve downloaded this and added the shortcut – but it seems to be behaving in the manner that David Winograd described above. When I run the app, it goes back to the front of the file, plays for 4 seconds (what I altered the blue script to do) and then jumps to the end of the file and starts recording.
    Like David, I’d love to hear if I still need to tweak a setting in TW to work this fantastic script properly.
    Thanks for all your hard work on this – you are obviously a genius.
    -c

  3. Hi Steven, Me Three on David and Catherine’s problem. I’m sure it’s just a setting that needs to be tweaked, but I can’t figure out what it is. I checked the setting Mike Jacobs mentioned and everything seems good there but it still jumps to the beginning of the recording and plays the first three seconds. Thanks!

    1. Hello Shiromi! The problem seems to be related to how “zoomed in” you are in TwistedWave. Email me directly if you are still stuck. You and I can compare screenshots and determine what’s going on.

  4. Hi Steven, so sorry for not getting back sooner. I’ve been doing back-to-back audiobook work these past few months and making do with Studio One. But, I just saw your comment on your other thread in regards to 1/2 seconds, and that did the trick. It’s working great. Thank you!

  5. Hi Steven,

    Thank you for creating this. I’m sure I’ve done something wrong (as working with automator is completely foreign to me), but it seems that when I press the command everything to the right of the cursor gets deleted. If I want to use this feature to go back and do punch ins at the end of a recording session, for example, how can I set it to only record over a small section rather than the remaining recording?

    Also, how do I set it to give me a little more roll time/lead in before the punch in?

    Any insight you can provide would be appreciated.

    Thanks,
    Rachel

    1. Hi Rachel,
      You are misunderstanding Punch and Roll in this context. You are meant to do pickups during the record. It is not about going back afterward and inserting a fix.

      You are describing setting a “Punch In” and “Punch Out” point. For that, you will need to record with a real DAW like Reaper, ProTools, Logic Pro, Ardour, Studio One, etc.

      Changing parameters like the pre-roll time is all described in the READ ME file.

      Steven

  6. Steven,
    I just got around to really trying to get this to work…AND IT DID! I had to tinker withe script in terms of the times and the “30” times thing and now it works nearly perfectly! I have just started a new audiobook and I will try and implement this new P&R technique. I hope it save me time on the back end as editing via the markers wasn’t hard but it did consume time. Thanks!

    1. Hello Jean,
      If you choose a shortcut that is already in use, it can cause a problem. Try assigning a shortcut that uses the CTRL key as part of it, since CTRL is rarely used for Mac shortcuts.

  7. Hey Steven!
    I think the most recent TW update erased or disabled the Punch and roll script you helped us set up. All was great and today I tried to use it and nothing… Have you heard of any other folks having this issue?

    1. Sorry Andrew, your report is the first I’ve heard of anything. I would suggest rebooting your Mac and setting up the shortcut again from scratch.

      Since the script is simply using built-in TwistedWave functionality, unless Thomas is removing features from TwistedWave, it should still function.

      1. I will try the reboot. Though, I did actually just do that yesterday. I redid the whole script process renaming it so I have I two punch and roll scripts one enabled and one, the old one, disabled. I may email ThOma’s. He was very very helpful in the past after a TW update went screwy!

        Thanks Steven!

  8. HI Steven, thank you so much for creating this! I’m using Adobe Audition CC on a Mac, and I’m having an issue where I can run the script from the Script Editor, but no shortcut I use seems to work. Do you have any suggestions? Thanks again!

    1. Hi Katherine. Most often the problem is caused by choosing shortcuts in use by other parts of the system. Have you tried using something like CTRL+DOWN-ARROW or OPT+DOWN-ARROW (less likely to be used on a Mac) as shortcuts?

      1. Thank you for the advice, I had tried that but playing around with different shortcut keys got it to work eventually. Thanks again!

Leave a Reply

Your email address will not be published. Required fields are marked *